Exchange 2010 backup failed with status code 2 under Netbackup Activity Monitor

Posted on July 13, 2011

0


Environment

Netbackup Server = 7.1

Netbackup Client = 7.1

 

OS of Exchange and Veritas Netbackup Server = win2008 R2

Exchange Server = 2010 (two node HA. “half mailboxes running on each node”)

Exchange 2010 HA Details

Exchange Server Node1 has a database (DB1) of let suppose 50Mailboxes.

Exchange Server Node2 has a database (DB2) of let suppose 50 other Mailboxes.

Exchange Server node1 replicating its database to Exchange Server node2 (replicating not on/over node2 DB)

Exchange Server node2 replicating its database to Exchange Server node1 (replicating not on/over node1 DB)

See the below SNAP for reference of the Exchange2010 HA scenario in which both databases backup we will take via NetBackup Server.

 

Note:

The above snap is just to show as an example so that all can understand what is the scenario. Imagine that each Exchange 2010 hosts one Database.

For more details about the environment see the below link:

https://www-secure.symantec.com/connect/articles/exchange-server-2010-backup-databases-and-restore-rdb

The problem is being faced while backup of Exchange2010. Although I have been backing up Exchange 2010 via Virtual DAG successfully. See  the below Activity Monitor.

 

Activity Monitor

6/12/2011 12:45:39 PM – Info nbjm(pid=1248) requesting MEDIA_SERVER_ONLY resources from RB for backup job (jobid=19788, request id:{4819D133-0AFA-46C7-B6ED-E95FC07CAED3})

6/12/2011 12:45:39 PM – requesting resource NBU-Server-netbkup-hcart-robot-tld-0

6/12/2011 12:45:39 PM – requesting resource NBU-Server-netbkup.NBU_CLIENT.MAXJOBS.VirtualDAG

6/12/2011 12:45:39 PM – requesting resource NBU-Server-netbkup.NBU_POLICY.MAXJOBS.Exchange2010

6/12/2011 12:45:39 PM – requesting resource EXCHANGE_RESOLVER.NBU-Server-netbkup.Exchange2010.VirtualDAG

6/12/2011 12:45:39 PM – granted resource NBU-Server-netbkup.NBU_CLIENT.MAXJOBS.VirtualDAG

6/12/2011 12:45:39 PM – granted resource NBU-Server-netbkup.NBU_POLICY.MAXJOBS.Exchange2010

6/12/2011 12:45:39 PM – granted resource EXCHANGE_RESOLVER.NBU-Server-netbkup.Exchange2010.VirtualDAG

6/12/2011 12:45:39 PM – estimated 544369198 Kbytes needed

6/12/2011 12:45:39 PM – begin Parent Job

6/12/2011 12:45:39 PM – begin Unknown Type, Start Notify Script

6/12/2011 12:45:39 PM – Info RUNCMD(pid=4256) started

6/12/2011 12:45:39 PM – Info RUNCMD(pid=4256) exiting with status: 0

Status 0

6/12/2011 12:45:39 PM – end Unknown Type, Start Notify Script; elapsed time: 00:00:00

6/12/2011 12:45:39 PM – begin Unknown Type, Step By Condition

Status 0

6/12/2011 12:45:39 PM – end Unknown Type, Step By Condition; elapsed time: 00:00:00

6/12/2011 12:45:39 PM – begin Unknown Type, Read File List

Status 0

6/12/2011 12:45:39 PM – end Unknown Type, Read File List; elapsed time: 00:00:00

6/12/2011 12:45:39 PM – begin Unknown Type, Resolver Discovery

6/12/2011 12:45:39 PM – started process bpbrm (6652)

6/12/2011 12:45:46 PM – Info bpbrm(pid=6652) client_pid=1248

6/12/2011 12:45:46 PM – Info bpbrm(pid=6652) from client VirtualDAG: TRV – BPRESOLVER has executed on server (PRI-MBX2)

6/12/2011 12:45:47 PM – Info bpresolver(pid=1248) done.  status: 2

6/12/2011 12:45:47 PM – Error bpbrm(pid=6652) no worklist items returned from bpresolver on client  VirtualDAG

6/12/2011 12:45:52 PM – Info bpresolver(pid=1248) done. status: 2: none of the requested files were backed up

Status 2

6/12/2011 12:45:52 PM – end Unknown Type, Resolver Discovery; elapsed time: 00:00:13

6/12/2011 12:45:52 PM – begin Unknown Type, Stop On Error

Status 0

6/12/2011 12:45:52 PM – end Unknown Type, Stop On Error; elapsed time: 00:00:00

6/12/2011 12:45:52 PM – begin Unknown Type, End Notify Script

6/12/2011 12:45:52 PM – Info RUNCMD(pid=8020) started

6/12/2011 12:45:52 PM – Info RUNCMD(pid=8020) exiting with status: 0

Status 0

6/12/2011 12:45:52 PM – end Unknown Type, End Notify Script; elapsed time: 00:00:00

Status 2

6/12/2011 12:45:52 PM – end Parent Job; elapsed time: 00:00:13

none of the requested files were backed up(2)

 

Resolution suggessted by Symantec

http://www.symantec.com/business/support/index?page=content&id=TECH125355&key=15156&actp=LIST

 

Resolution

The above may be one resolution of this problem but this is not the case with me. Actually Firewall is enabled on both windows 2008 nodes and I only enable the ports use for Netbackup with the default open ports of Win2008 Server R2. See the Netbackup ports below which I opened.

 

Note:

Open the below ports in case to keep the OS Firewall ON. or your Exchange 2010 Nodes are behind Network/etc Firewall.

13724(vnetd)

13782(bpcd)

1556(pbx)

13720(bprd)

 

What I observed that I was not able to see the databases under the backup selection of Netbackup Server Policy when I try to see that the Exchange Server database.

and second main issue is

I did reset the password of domain user which runs the Netbackup Client Service on both nodes of Exchange 2010. But the password did not changed under Service Logon Tab=>This Account. So I replaced the password with new one and the backup starts successfully.

Advertisements
Posted in: SFHA / VCS