Error nbjm(pid=3908) NBU status: 830, EMM status: No drives are available

Posted on July 13, 2011

0


I have two tape libraries in different environments. I wanted to restore the tape cartridge1 data from the  Tape Library1 to Tape Library2.  After completing all the prerequisites while starting the restore process i was facing the below problem.

 

Environment

Netbackup Server version = 7.1

OS of Netbackup Server = Win2008 R2

Netbackup Client version = 7.1

 

Activity Monitor

3/25/2011 12:37:44 PM – begin Restore

3/25/2011 12:37:46 PM – 1 images required

3/25/2011 12:37:46 PM – media 2010L4 required

3/25/2011 12:37:49 PM – restoring image SERVER-CR_1298966565

3/25/2011 12:37:50 PM – Info bpbrm(pid=5292) telling media manager to start restore on client

3/25/2011 12:37:52 PM – Info bpbrm(pid=5984) listening for client connection

3/25/2011 12:37:54 PM – Error bptm(pid=6012) NBJM returned an extended error status: No drives are available (2001)

3/25/2011 12:37:54 PM – requesting resource 2010L4

3/25/2011 12:37:54 PM – Error nbjm(pid=3908) NBU status: 830, EMM status: No drives are available   

3/25/2011 12:37:54 PM – Error nbjm(pid=3908) NBU status: 830, EMM status: No drives are available   

3/25/2011 12:37:57 PM – Error bptm(pid=5900) The following files/folders were not restored:

3/25/2011 12:37:57 PM – Error bptm(pid=5900) UTF – /Server-CR.MSSQL7.SERVER-CR.db.CPSBUSINESCCD.~.7.001of001.20110301130007..C

3/25/2011 12:37:57 PM – Error bptm(pid=5900) UTF – /Server-CR.MSSQL7.SERVER-CR.db.CPSBUSINESCCD.~.7.001of001.20110301130007..C

3/25/2011 12:37:57 PM – Error bptm(pid=5900) UTF – /Server-CR.MSSQL7.SERVER-CR.db.CPSBUSINESCCD.~.7.001of001.20110301130007..C

3/25/2011 12:37:57 PM – Error bptm(pid=5900) UTF – /Server-CR.MSSQL7.SERVER-CR.db.CPSBUSINESCCD.~.7.001of001.20110301130007..C

3/25/2011 12:37:57 PM – Error bptm(pid=5900) UTF – /Server-CR.MSSQL7.SERVER-CR.db.CPSBUSINESCCD.~.7.001of001.20110301130007..C

3/25/2011 12:37:58 PM – Info bpbrm(pid=5292) got ERROR 252 from media manager

3/25/2011 12:37:58 PM – Info bpbrm(pid=5292) killing bpbrm child 5984.

3/25/2011 12:37:58 PM – restored image SERVER-CR_1298966565 – (extended error status has been encountered, check logs(252)); restore time 00:00:09

3/25/2011 12:37:58 PM – Info bpbrm(pid=5984) accepted connection from client

3/25/2011 12:37:58 PM – Info tar32(pid=3640) Restore started.

3/25/2011 12:37:58 PM – connected

3/25/2011 12:38:03 PM – end Restore; elapsed time: 00:00:19

invalid error number(2826)

 

Drivers are also UP

I have also checked my Drives which also UP properly. See the below details for reference.

 

C:\Program Files\VERITAS\Volmgr\bin>tpconfig.exe -d

Id  DriveName           Type   Residence

SCSI coordinates/Path                                            Status

****************************************************************************

2   IBM.ULT3580-TD5.000  hcart3 TLD(1)  DRIVE=3

{3,0,2,0}                                                        UP

{4,0,3,0}                                                        UP

3   IBM.ULT3580-TD5.001  hcart3 TLD(1)  DRIVE=4

{3,0,3,0}                                                        UP

{4,0,2,0}                                                        UP

4   IBM.ULT3580-TD5.002  hcart3 TLD(1)  DRIVE=5

{3,0,4,0}                                                        UP

{4,0,4,0}                                                        UP

5   IBM.ULT3580-TD5.003  hcart3 TLD(1)  DRIVE=6

{3,0,5,0}                                                        UP

6   IBM.ULT3580-TD5.004  hcart3 TLD(1)  DRIVE=1

{3,0,6,0}                                                        UP

{4,0,5,0}                                                        UP

7   IBM.ULT3580-TD5.005  hcart3 TLD(1)  DRIVE=2

{3,0,7,0}                                                        UP

{4,0,6,0}                                                        UP

 

Currently defined robotics are:

TLD(1)     SCSI coordinates = {3,0,5,1}

 

EMM Server = server1

 

 

 

Resolution

Actually the problem what i have noticed is that the Tape Cartridge which i have inserted from the Tape Librry1 to Tape Librry 2 have different media Type. The Tape Cartridge1 has the HCART as the media type and the Tape Library2 configured to faciliate HCART3 as media type. So i just changed the media type via the below procedure.

C:\Program Files\VERITAS\Volmgr\bin>vmchange.exe -new_mt HCART3 -m 2010L4

Advertisements